Intermitent connection
Incident Report for Certify
Resolved
Our service provide has confirmed that the networking issue has been resolved as of 10:28 a.m. ET.
Posted 2 months ago. Jun 14, 2019 - 11:34 EDT
Update
Certify's service provider has identified a networking issue and is currently working on a resolution.
Posted 2 months ago. Jun 14, 2019 - 10:34 EDT
Investigating
We are currently investigating reports of intermittent connection issues with the Certify and Certify Mobile applications
Posted 2 months ago. Jun 14, 2019 - 10:18 EDT
This incident affected: Certify.com Public Web Site, Certify Web Site Login, and Certify Mobile Synchronizing.