Disapprove Expense Report Issue
Incident Report for Certify
Resolved
The problem has been resolved.
Posted over 4 years ago. Feb 18, 2015 - 14:04 EST
Investigating
The Disapprove Expense Report function is reportedly not working correctly. We are investigating now.
Posted over 4 years ago. Feb 18, 2015 - 14:03 EST