Certify.com Issue with SSL Certificate
Incident Report for Certify
Monitoring
Certify is currently operational with an SSL certificate which supports SSO.
The situation is still being monitored closely. Please contact support@certify.com with any continued issues.
Posted Jul 12, 2020 - 16:41 EDT
Identified
Due to a compliance issue, DigiCert has revoked Certify's www.certify.com site certificate as well as the certificates of a reported 50,000 other customers. An updated certificate is in place, Certify is continuing to address an issue which is likely to continue affecting customers using Single Sign-on (SSO).

For more information, see: https://knowledge.digicert.com/alerts/DigiCert-ICA-Replacement
Posted Jul 12, 2020 - 08:41 EDT
Investigating
We're currently experiencing a problem with our SSL certificate which we're investigating. Currently, SSO customers are likely to be affected.
Posted Jul 12, 2020 - 05:57 EDT
This incident affects: Single Sign-On to Certify.com and SSL Certificates.