Telephone Support Unavailable
Incident Report for Certify
Resolved
Certify's telephone system is back on line and phone support is available.
Posted about 2 years ago. Sep 19, 2017 - 16:35 EDT
Identified
We are experiencing intermittent problems with our telephone system, which is affecting in-bound calling for technical support. Our VoIP team is working on the resolution now. All other support channels remain open, so please try submitting tickets online or by email. Will update soon.
Posted about 2 years ago. Sep 19, 2017 - 14:42 EDT