CertifyAP is currently going under maintenance

Incident Report for Emburse Professional

Resolved

This incident has been resolved.
Posted Apr 22, 2023 - 14:46 EDT

Update

We are continuing to investigate this issue.
Posted Apr 22, 2023 - 14:45 EDT

Update

We are continuing to investigate this issue.
Posted Apr 22, 2023 - 14:42 EDT

Investigating

We are currently investigating this issue.
Posted Apr 22, 2023 - 10:06 EDT
This incident affected: Emburse Services (Certify AP).