Site Performance Issues
Incident Report for Certify
Resolved
This incident has been resolved.
Posted Aug 16, 2021 - 15:41 EDT
Monitoring
Performance-related fixes have been applied and monitoring continues.
Posted Aug 16, 2021 - 14:40 EDT
Investigating
We are currently investigating this issue.
Posted Aug 16, 2021 - 11:28 EDT
This incident affected: Certify.com Website.