Delayed OCR Processing Times

Incident Report for Emburse Professional

Resolved

The issue has been resolved and OCR receipt processing has returned to normal. Thank you for your patience while we addressed this issue.
Posted May 29, 2026 - 13:14 EDT

Investigating

We are currently investigating an issue impacting receipt OCR processing times.
Posted May 29, 2026 - 11:41 EDT
This incident affected: Receipt Capture (OCR Receipt Parsing).