Certify expense and AP degraded performance

Incident Report for Emburse Professional

Resolved

This incident has been resolved.
Posted Oct 24, 2022 - 13:57 EDT

Update

Maintenance is now complete, service is back to normal.
Posted Oct 24, 2022 - 13:55 EDT

Investigating

Certify Expense and AP will be going under short maintenance, customers may experience login issue during that time
Posted Oct 24, 2022 - 12:13 EDT
This incident affected: Authentication (Application Login) and Emburse Services (Certify AP).