Users unable to Login

Incident Report for Emburse Professional

Resolved

We have identified and corrected the authentication issue and all users are now able to log in.
Posted Dec 21, 2025 - 20:25 EST

Investigating

We are currently investigating an issue which is preventing users from logging in to the Emburse Professional and Certify AP applications.
Posted Dec 21, 2025 - 19:54 EST
This incident affected: Authentication (Single Sign-On, Application Login).