Degraded Performance
Incident Report for Certify
Resolved
This incident has been resolved.
Posted 17 days ago. Sep 30, 2019 - 16:54 EDT
Update
We are continuing to investigate this issue.
Posted 17 days ago. Sep 30, 2019 - 11:55 EDT
Investigating
Certify is experiencing degraded performance this morning (9/30/2019). We are actively working to identify the issue.
Posted 17 days ago. Sep 30, 2019 - 11:36 EDT
This incident affected: Certify Web Site Login and Certify Mobile Synchronizing.