Users Unable to Login

Incident Report for Emburse Professional

Resolved

The issue has been resolved and users are now able to log in.
Posted May 07, 2026 - 20:18 EDT

Investigating

We are currently investigating an issue which is preventing users from logging in to the application.
Posted May 07, 2026 - 20:04 EDT
This incident affected: Authentication (Application Login).