Google Maps Problem
Incident Report for Certify
Resolved
The problem has been resolved and all Map It! requests are working properly.
Posted over 4 years ago. Apr 21, 2015 - 10:08 EDT
Investigating
Google Maps for Map It! functionality is not working on one of the web nodes. Investigating.
Posted over 4 years ago. Apr 21, 2015 - 08:57 EDT