Users Unable to Login

Incident Report for Emburse Professional

Resolved

This incident has been resolved. All users can access the application without issue.
Posted Feb 21, 2025 - 08:36 EST

Monitoring

The issue has been remediated and users are able to log in. We are continuing to monitor the situation.
Posted Feb 21, 2025 - 08:00 EST

Investigating

We are currently investigating an issue which is preventing all users from logging in to the Emburse Professional application. We will provide updates as soon as they become available. We apologize for this inconvenience.
Posted Feb 21, 2025 - 07:20 EST
This incident affected: Authentication (Single Sign-On, Application Login).