Site Outage

Incident Report for Emburse Professional

Resolved

The incident has been resolved. Thank you for your patience.
Posted May 31, 2024 - 18:14 EDT

Update

We are continuing to monitor for any further issues.
Posted May 31, 2024 - 16:39 EDT

Monitoring

A fix has been applied, and we are monitoring results.
Posted May 31, 2024 - 16:38 EDT

Identified

The issue has been identified and we are working on a resolution.
Posted May 31, 2024 - 15:18 EDT

Investigating

Emburse are aware of a present Certify Expense site outage and are investigating.
Posted May 31, 2024 - 14:58 EDT
This incident affected: Authentication (Application Login).