site login issues

Incident Report for Emburse Professional

Resolved

This incident is resolved.
Posted Jul 10, 2023 - 10:12 EDT

Investigating

We are currently investigating an issue which is preventing some users from accessing Certify.
Posted Jul 07, 2023 - 16:12 EDT
This incident affected: Authentication (Application Login).