Degraded performance
Incident Report for Certify
Resolved
A fix has been implemented, we are monitoring results.
Posted Feb 07, 2022 - 13:24 EST
Investigating
Some customers may be experiencing issues login to Certify as well as creating expense reports.
Our engineering team is actively investigating.
Posted Feb 07, 2022 - 09:11 EST
This incident affected: Certify Web Site Login, Single Sign-On to Certify.com, Expense Report Create and Submit, Expense Report Approval, and Expense Report Processing.