Email Notifications

Incident Report for Emburse Professional

Resolved

The fix has been deployed and should no longer be impacting users. We will continue to monitor and provide additional updates if necessary.
Posted Aug 22, 2025 - 14:45 EDT

Identified

This issue impacting email notifications has been identified and a fix is being deployed. We will notify all customers once the issue has been fully resolved.
Posted Aug 22, 2025 - 12:52 EDT

Investigating

We are aware of an issue impacting email notifications and are investigating. Please note that email notifications for password recovery and multi-factor authentication remain operational.
Posted Aug 22, 2025 - 10:49 EDT
This incident affected: Notifications (Outbound Email Delivery).